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1 EVK features 

 USB connectivity to PCs/ laptops 

 Up to 2000Hz sampling rate supported 

 Temperature measurements supported 

 Service mode access 
o Full gyro module information 
o Full gyro module configuration capability 
o Detailed gyro module diagnostics 
o Help section 

 Measure panel 
o Data presentations and save data to file capability 
o Custom scale and zoom functions 
o CRC check 

 Logging panel 
o Support for any measurement duration, only limited 

by hard drive, available memory and processor 
capacity of PC 

o Various stop criteria for measurements available ('Manually', 'No. of samples' or 'Time elapsed') 

 Measurements of up to 4 gyro modules simultaneously supported (requires additional cables depending on 
the type of evaluation kit) 

 
1.1 General description 
The evaluation kit provides measurement and configuration access to STIM210 gyro. Configuration, graphical result 
presentation and saving data to file functions are supported. The single voltage supply required for the gyro module 
operation is provided from an USB port.  
 

Feature Available 

Portability across PC's No 

Hardware installation required? Yes 

Gyro output available? Yes 

Temperature data available? Yes 

TOV, PPS, CRS, External trigger  
available? 

Yes (break-out cable) 

Transmission rate supported Up to 5.34Mbit/s 
Table 1: Features of PCI/PCIe kit 
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Figure 1 Wiring diagram 

1.2 Configurable and readable parameters 
 
Configurable parameters in Service Mode:  
 

 Output format (angular rate, increment angle etc.) 

 Datagram format 

 Sampling rate 

 Bandwidth / Low pass filter frequency  

 RS-422 transmission bit rate 

 Number of stop bits in datagram 

 Parity 

 Line/ Datagram termination 
 
Readable parameters:  
 

 Part number 

 Serial number 

 Firmware revision 

 Hardware revision 

 Gyro module diagnostics 
 
Detailed diagnostic information including RAM and flash checks, stack handling checks, status of internal voltage 
supply references, and various parameter reports for each measurement axis is available in SERVICE mode. 
 
Note: Time of Validity (TOV) and external trigger functionalities of STIM210 are not supported by the EVK PC-
software. 

 
2 Kit contents 
 

 USB to RS422 interface cable with USB power supply connector 

 Memory stick with  
o PC software 
o FTDI CDM20824 serial driver for Windows  
o User manual  for evaluation kit 

 Tool for fixing connector of communication and power cable to the gyro module 
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 Hard copy of User manual 
 

Note that the evaluation kit does not include a STIM210 gyro module. This must be ordered separately. 
 
 
 
3 System requirements 
 

 Windows XP SP2 (or later), Windows Vista, Windows 7 (32/ 64bit) , Windows 10 (32/ 64bit) 

 2 free USB ports 

 Quad core processor recommended (when simultaneously logging data from two gyro modules) 
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4 Getting started 
 
Preparing your system involves the following steps: 

 
4.1 USB kit Installation of FTDI serial driver 
 
To install the drivers for the FTDI serial driver under Windows, follow the instructions below: 
 

 Connect the USB-RS422 plug to a spare USB port on your PC. 

 If there is an available Internet connection, some Windows versions will silently connect to the Windows 
Update website and install a suitable driver 

 In the event that no automatic installation takes place, please refer to the set-up guide from FTDI: 
http://www.ftdichip.com/Support/Documents/InstallGuides.htm 

  

http://www.ftdichip.com/Support/Documents/InstallGuides.htm
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4.2 Verification and configuration of serial driver 
 
Launch Device Manager. See Control Panel -> Hardware and Sound -> Devices and Printers. 
 
Verify that the driver installation has completed successfully: 
  

 
Figure 1: COM port assignments for USB cable in Windows 7. 

 

 
 
Make a note of the assigned COM port value(s) information. This will be needed later for connecting to the STIM210 
from the PC software. 
 
 
Right-click "USB Serial Port (COM<n>)" and select "Properties" 
 

 
Select "Advanced" from the "Port Setting" tab. 
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Set the "Receive (Bytes)" and Transmit (Bytes) settings to 256. 
Press OK twice. 
 
The computer may have to be restarted for the changes to take effect. 
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4.3 Installation of PC software 
 
Install the PC software by running "setup.exe" found on the included memory-stick. Follow the on-screen instructions 
to complete the installation. The PC software also can be downloaded from the Sensonor support site. Check this site 
regularly for updates. 
 
5 Connecting the STIM to your PC 
 

Micro-D

P-USB

USB-
RS422

 
Figure 2 Connecting the STIM210 to the computer 

 

6 Using PC software 
 

1. Navigate to the ‘Sensonor evaluation tools’ folder from Windows start menu. Click on the shortcut named 
"STIM210 EVK" to start the PC software. For full functionality, the computer user should have Local 
Administrator rights. 

 

 
 

Figure 3: Starting PC software from Windows start menu 

 
 

2. A pop-up box appears, asking for a parameter (.INI) file. Select the INI-file (available in the installation folder by 
default) and press "Load" 

http://www.sensonor.com/help-menu/support.aspx
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Figure 4: INI-file selection 

 
3. A pop-up box for software registration appears. Fill in the open fields and press "Submit". The default email 

client opens. Press "Send" in order to complete this step (user information is sent to Sensonor for support 
issues). This step will only have to be completed once. 

 
Figure 5: Welcome message and software registration 
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4. The Normal mode panel is shown 

  
Figure 6: Normal mode panel after selecting INI-file 

 
5. Verify the correct COM port settings in the Parameters view. If needed port # setting needs to be changed, do 

this by double clicking on the value and enter correct value. The default password to edit is ‘stim’. 
 

  
Figure 7: Edit the INI-file in order to verify correct COM port settings 
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6. Go back to Normal mode panel. Connect to and open COM port by pressing the ‘Connect to HW’ button. A 
green LED light indicates that the COM port is active 

 
Figure 8: Normal mode panel after first hardware connection 

7. Switch the ’ Initiate power-on sequence’ control switch position to ’On’ position. Do not insert the power supply 
cable at this point. The pop-up message asking for confirmation of bitrate appears. Press OK. 

 
Figure 9: Confirm bitrate 
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8. A pop-up message telling "Connect power cable to voltage supply and then press OK to continue" appears. 
First insert the red USB connector into a free USB port of the PC/ laptop and then confirm the supply voltage is 
applied by pressing ‘OK’ 

 
Figure 10: Confirm power supply is switched on 

 
9. A green LED (Data arriving from device n) indicates that data is received from the gyro module(s). Verify the 

communication to module by clicking on the ‘Request serial# DG’ button. An example of such a result is shown 
in Figure 11. The system is now ready for use 
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Figure 11: Result of sending ’Request serial# DG’ to the STIM210 



 

USER MANUAL EvaluationTools 

STIM210 Evaluation Kit - USB 
 

 
DOK452 rev.1 
                                          14/22                                                              2020 
 

7 Introduction to PC software 
 
7.1 Panels overview 
In addition to the panel already shown (Normal mode and Parameters panel), other panels are also available: 

7.1.1 Service mode panel 

 

 
Figure 12: Service mode panel 
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7.1.2 Measure panel 

 
Figure 13: Measure panel 

7.1.3 Logging panel 

 

 
Figure 14: Logging panel (for saving data to file) 
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7.2 Main panel menu 
 
Table 2: The options available from the main panel menu. 

Menu Description 

‘File’ → ‘New parameter file’ Creates a new INI-file with default settings. Note that the new INI-file must be 
edited to match the hardware and gyro module configuration settings. 

‘File’ → ‘Open parameter file’ For loading an existing INI-file 

‘File’ → ‘Save parameter file as’ To save current parameter settings with a new file name 

‘File’ → ‘Print parameters’ For printing the current ‘Parameters’ content on the default printer 

‘File’ → ‘Edit parameters’ Edit the ‘Parameters’ content 

‘File’ → ‘Exit’ Exit program 

‘Help’ → ‘Check for updates’ Opens the Sensonor support site in a web browser. New and updated Drivers, 
PC software and user manuals can be downloaded 

‘Help’ → ‘About’ Information about the program (Program name, publisher and software revision 
number) 

 

 
Figure 15: File Menu 

 
Figure 16: Help menu 
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7.3 Normal mode panel descriptions 
 
 
Table 3: Normal mode panel descriptions. 

Panel unit Functionality and description 

Connect to HW Connects to interface hardware. Opens COM port according to settings specified in 
active parameter file 

LED Indicator for hardware connection. A GREEN light indicates the COM port is 
opened 

Disconnect from HW Disconnects from interface hardware. Closes the COM port 

Initiate power-on sequence 
switch 

Toggles supply voltage if configured with an external power supply. Controls 
certain functions of the PC software 

Device box Device number (and corresponding COM port) according to active parameter file. 
Selects which gyro module is activated for datagram requests in Normal mode, 
Service mode operations and measurements in Measure panel. Does not apply for 
Logging panel 

Reset device button Resets the gyro module. Sends reset command (‘R’) 

Request config DG button Sends command (‘C’) to receive configuration datagram 

Request identity DG button Sends command (‘N’) to receive part number datagram 

Request serial# DG button Sends command (‘I’) to receive serial number datagram 

Request Ext status button Sends command (‘E’) to receive extended error information datagram 

Response window Displays response to special datagram requests ('C', 'N' and ‘I’ datagrams) 

 
 
7.4 Service mode panel descriptions 
 
Service mode is used for gyro module configuration. 
 
Service mode is entered by clicking on the Service mode tab next to the Normal mode tab after the gyro module has 
been powered up. Service mode usage, functionalities and descriptions are listed in Table 4. Exit from Service mode 
to Normal mode by selecting one of the other panel tabs (Normal, Logging, Service or Parameter panel tab). 
 
Note: Changes made for the gyro module in Service mode are only stored permanently in flash memory when the 
save command (‘s’) subsequently is sent to the gyro module. 
 
 
Table 4: Service mode panel descriptions. 

Panel unit Functionality and description 

Available commands window Shows a list of available commands. See product datasheet for details 

Complete command window Contains the complete command to be sent. The command is auto-completed by 
the software during usage of the listings in the Available commands window. Left 
click inside the Complete command window brings up a list of previously sent 
commands. Right click enables manual command entry 

Send command button Sends command to the gyro module 

Active device indicator Indicates active gyro module. Corresponding COM port is specified in the active 
parameter file 

Command response window Shows the responses to commands from the gyro module. See product datasheet 
for details 

Erase button Clears the content of the command response window 

Save button Saves the content of the command response window to a text file with a date and 
time tag 

7.5 Measure panel descriptions 
 

 
Table 5: Measure panel descriptions. 

Panel unit Functionality and description 

Measure button Starts a measurement series 

Samples box Defines the number of samples to be collected (max 50 MS) 
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Save to file button Saves data from a completed measurement series to a result file. The file path 
defined in the active parameter file is proposed 

X-, Y- and Z-axis check boxes Selects which axis data to present in the graph area (up to 3 axes can be plotted 
simultaneously) 

Relative and absolute toggle 
switch 

When set to ‘Absolute’, all results are plotted as received. When set to ‘Relative’ 
the curves are translated so that the first measurement is shown in the plot as zero. 

Active device indicator Indicates active gyro module. Corresponding COM port is specified in the active 
parameter file 

CRC and DG-ID LEDS Status on all CRC checks and DG-IDs. GREEN = OK, RED = FAIL 

Data box Selects which datagram content to be shown. Several options are available, 
depending on the active datagram type. Left click inside box to display available 
selections. The plot updates immediately if a measurement series has been done. 

Scale box Enables user to change Y-axis scaling (Full range, User defined, or Auto). Left click 
inside box to display available selections 

Sample rate box Displays the sample rate used in measurement 

Unit box Displays the output unit for all measurements (Angular Rate, Incremental Angle, 
etc.) 

DG type box Displays the type of datagram received 

Save to disk icon Saves the plot to a .JPG file 

Print icon Prints a picture of the plot to the default printer 

1:1 icon Resets zoom level to 1:1 (if ZOOM is active. See below) 

Zoom icon Enables a custom zoom of the presented results in the strip chart (graph area) 
according to placement of the cursors 

Cursors (On/Off) switch Enables usage of cursors (default is Off) 

Cursor 1 Shows the location of cursor no 1 

Cursor 2 Shows the location of cursor no 2 

Delta Shows the delta between the two cursor locations (X and Y values) 

Progress bar A blue continuous line above plot area shows the measurement series progress 

Lower bar on panel Shows the INI-file in use and the active mode (INTERACTIVE MEASUREMENTS) 

 
Saved data: 
An example of a result file is shown in Figure 17, for a standard datagram measurement series of gyro module # 1. A 
description of each of the columns of the data log file is found in the table that follows. 
 

 
Figure 17: Result file exampleNY FIGUR 

 
 

Table 6: Result file example. (Standard datagram content written to file). 

DG-
type 

Col. # Heading Comments 

S
ta

n
d

a
rd

 

 

1 
Time[s] 

Time in seconds (derived from sample rate). First 
sample is always zero. 

2 GYRO_X Gyro signal X-axis 

3 GYRO_Y Gyro signal Y-axis 

4 GYRO_Z Gyro signal Z-axis 

5 GYRO_STS Status-byte for gyro 

6 GYRO_TMP_X Temperature, X-axis gyro 

7 GYRO_TMP_Y Temperature, Y-axis gyro 
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8 GYRO_TMP_Z Temperature, Z-axis gyro 

9 GYRO_TMP_STS Gyro temperature status 

10 Counter Sample counter. See product datasheet for details 

11 Latency Sample latency. See product datasheet for details 

12 RxCRC Received CRC 

13 CalCRC Calculated CRC 

14 DG_ID Datagram identifier 
 
 

 
7.6 Logging panel 
 
 
 
Table 7: Logging panel descriptions. 

Panel unit Functionality and description 

Start button Starts data logging 

Stop button Stops data logging 

Stop criteria slide User can select between “Manually”, “No of samples” and “Time 
elapsed” for stopping a measurement series 

Samples box Used for defining number of samples when logging a finite number of 
samples 

Average box Used for specifying how many samples should be averaged before 
saving the averaged value to file. If values is ‘1’ no averaging is done 

Time elapsed Shows the time elapsed since start of test 

Samples acquired Shows number of samples acquired 

CRC_errors Shows number of CRC errors (normally 0, otherwise the user should 
consider to reject results data in any analysis) 

Resynch’s Increments from 0 to a number if any re-synchronisations are needed 
in order to re-establish data collections from module 

 
Log to file capability: 
 

 Quad core processor is recommended when measuring on two gyro modules simultaneously  

 The size of the log file is only limited by the available space on the storage media in use 

 The path for result file storage is defined in the active parameter file 

 The program should be run with administrator rights to ensure the creation and storage of the result file 
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7.7 Parameters panel 
 
 
Table 8: Parameters panel descriptions. 

Panel unit Functionality and description 

===== General parameters =====  

Password Current valid password to be able to edit the parameters list. The 
password is “stim” 

Folder for result-file storage Path to storage (e.g. “c:\userdata\test\") 

What priority will this program run with Instructs the program priority for the PC operation system 

What format to use for result files ASCII text by default. Can be changed to 8 byte binary 

Name of file with language definitions Application can be configured with language other than English 

===== Device communication ===== 
IMPORTANT MESSAGE: Always verify 
hardware connections and COM port settings 
before trying to connect to the device 

 

RS422 port # to device 1 Defining which COM port # to assigned to gyro module # 1 

RS422 port # to device 2 Defining which COM port # to assigned to gyro module # 2 

RS422 Bitrate [bit/s] RS422 bit rate selection 

RS422 Stopbit 1 or 2. Default is “1” 

RS422 parity None, odd or even. Default is “None” 

===== External Hardware =====  

The GPIB-card #  to use Interface for external power supply (optional). If card(s) are in use; 
the first card will be assigned to #0, second to #1, etc. Default value 
is “0” 

Type of power supply used External power supply (optional). Default "None" (not in use). 
Agilent E3631A, E3633A and E3644A are supported 

Interface that the power is connected with Interface type for external power supply (optional). Default "None" 
(not in use). RS232 (for Agilent E3631A only) and GPIB supported 

Port or address to power GPIB port for external power supply (optional). Default "0" (not in 
use). Selectable up to 31 

Voltage on output of power supply [V] Voltage output on external power supply (optional). Default value is 
5.1 V. Value should be within the supply voltage range of the gyro 
module. See product datasheet for details 

Current limit on output of power [A] Current limitation on external power supply (optional). Default value 
is 1.0 A 
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7.8 Messages from the program 
Messages that the program can display are listed inTable 9: 

 
Table 9: Possible messages given by the program. 

# Message Description 

1  
This application is already running! 
Stop loading of 2. instance... 

The program is already started, a second instance will 
not be allowed 

2  Wrong password entered! 
The password entered does not match the required one 
for this INI-file 

3  No response to message was received 
Did not receive the expected response to the sent 
service-mode command 

4  There is no measurement data available for storage 
To be able to save measurement data, there must be 
data available 

5  Unable to open the selected file 
Saving of measurement data failed, unable to open or 
create the selected file 

6  Unable to allocate the required memory 

Failed to acquire the requested number of datagrams 
from the gyro module due to error when trying to 
allocate memory for temporary storage 

7  No product identification datagram received 
Even after retries the, expected datagram is not 
received as response to command sent  

8  No configuration datagram received 
Even after retries the, expected datagram is not 
received as response to command sent 

9  No serial number datagram received 
Even after reties the, expected datagram is not received 
as response to command sent 

10 No datagrams received 

Failed to acquire the requested number of datagrams 
from the gyro module, no recognizable datagrams 
received 

11 Turn off device supply voltage 
Instruction to user when running without controlled 
power-supply 

12 Turn on device supply voltage 
Instruction to user when running without controlled 
power-supply 

13 Error encountered when trying to control voltage 

Power on sequence failed. Note that for the software to 
be able to read the special datagrams on power-on, the 
power supply must be applied exactly when instructed 
as described in previous chapters 

14 Unexpected DG-ID received ! 
When waiting for datagrams, unexpected datagrams are 
received 

15 Unable to read config DG to determine output unit ! 
Unable to read configuration datagram to determine the 
output unit 

16 Unable to synch with DG-stream ! 

Failed to acquire the requested number of datagrams 
from the gyro module, unable to get in synch with 
datagram stream 

17 
Error encountered when trying to print, check 
configuration ! 

Failed to print the graph, check that a printer is 
configured 
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18 Unable to create result-folder specified by parameter ! 
The specified pathname cannot be created, either due to 
access-rights or errors in the path specification 

19 Unable to enter service-mode ! 
Unable to enter service-mode, does not receive 
expected response to command. 

20 Unable to save parameters to active INI-file ! 
Error encountered when trying to save parameters onto 
INI-file 

21 Edit-mode of parameters is active, unable to exit ! 
The edit-mode of parameters are active, unable to exit 
the program until edit mode is ended 

22 

You are about to change the RS422 bit rate.  
If are you using the USB kit hardware provided by 
Sensonor, please notice that you will not be able to 
communicate with the device if you change to something 
else than supported 460800 b/s!  
For the PCI card there are no worries - it supports all 
available bit rates 

A warning to the user about limitations for certain RS422 
hardware 

23 
Unable to create/save to selected file, check access 
rights to folder 

Unable to open or create the specified file in the 
selected folder, try another filename and/or location. The 
reason may be lacking access rights to the folder, or 
illegal filename format 

24 
Unsupported datagram received When trying to read datagrams into memory a datagram 

type not supported by the EVK is detected 

 


